Cord / ConfigurEz: money to the trash??



  • Official comment
    Daniel Stallings

    Hi Carlos,

    I am sorry to hear about your poor experience with CÔRD. We'd be happy to troubleshoot the issue with you and get this resolved. We've sent an email from our support system, please keep an eye out for emails coming from I you don't see it soon, please check your junk/SPAM folder.

    Thank you,


    Comment actions Permalink
  • Paulhuizer

    Hello Daniel, I'm sorry to say, but I ran into the same sort of issues with a newly purchased Cord.

    The firmware update fails, which does not make things better. 

    Any help for this?

    Comment actions Permalink
  • Daniel Stallings

    Hi Paul,

    We saw your support request this morning and will respond there. 

    Thank you!


    Comment actions Permalink
  • Carlos B

    Hi Paul

    They very kindly tried to help me update the device through an alternative method, it was impossible

    Now I'm supposed to be waiting for a replacement with a new and functional one

    I'll tell you

    Comment actions Permalink
  • Carlos B

    As I said before, the team very kindly tried to help me solve my problem

    I received a new device at my house with updated firmware, but the same problems persist

    I'm trying to use the device as a bridge between my keiser m3i and my garmin epix 2

    the connection is absurdly unstable

    It is impossible to configure the device through the app without continually losing the connection, and when it seems that the configuration process has finished, the data is lost and I don't know if it is not broadcasting or I simply cannot see it from my garmin

    desperate, with the immense loss of time and money

    Comment actions Permalink

Please sign in to leave a comment.